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Introducing MVS/Quick-Ref for Windows

Preface
Welcome to release 6.5 of MVS/Quick-Ref for Windows, the essential reference tool for
programmers, operators and system administrators working with IBM’s MVS, OS/390 and
z/OS enterprise computing platforms.

This guide describes the features of MVS/Quick-Ref for Windows and will enable you to start
using the product immediately.  If you are an experienced Windows user, you should find that
this release requires little in the way of detailed explanation thanks to a completely new user
interface that looks familiar, and behaves in the way you would expect.

If the information you need is not available in the current MVS/Quick-Ref database, or if you
would like to see a specific feature or enhancement, please let us know. We want to make this
product as helpful to you as possible, so don't hesitate to send us your product improvement
suggestions.

If you need additional copies of this guide, they are available in the root directory on the
distribution DVD as an Adobe Acrobat® document.  The Acrobat® Reader is free and can be
downloaded from http://www.adobe.com.
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Overview
MVS/Quick-Ref for Windows offers many of the problem-solving features found in the
MVS/Quick-Ref mainframe product in a powerful and easy to use application.

The contents of the main database in MVS/Quick-Ref for Windows are exactly the same as
those supplied with the mainframe product.  Some of the reference information to be found in
the database includes:

Assembler Language Syntax

COBOL Language Syntax             

CICS Msgs and Codes

C/C++ Language Syntax           

OS/390, z/OS JES2 & JES3 Cmd
Syntax

CLIST Language Syntax Description

DB2 Messages and Codes         

JCL Statement Syntax

IBM Utilities & Service Aids

IMS Messages and Codes

JES2/JES3 Statement Syntax

CICS Command Syntax

IMS Utilities

ISPF Msgs, Services, Variables,
Macros

MQ/Series Messages

Netview Messages & Codes

OS/390 and z/OS Data Areas

OS/390 and z/OS SMF Record
Mappings

IPCS Messages & Commands

RMF Messages

UNIX Messages & Codes

UNIX Command Syntax

UNIX Callable Services

SQL Codes

SQL Statements Syntax         

MVS Messages and Codes

MVS Macros

Wait Code Description

DB2 Admin & Utility Guides

DB2/IMS Tools

Debug Utility & Tools Messages

Omegamon Products

PL/1 Language Syntax

REXX Language Syntax

SMP/E Messages & Commands

TSO Command Syntax Descriptions

TSO/E Messages & Codes

VS COBOL II Language Syntax

VTAM Messages

VTAM Commands Syntax

FTP Sub-Commands

Tivoli Storage Manager

Tivoli Workload Scheduler

Tivoli Business Systems Manager

Communications Server Msgs & codes

Security Server Messages Codes

WebSphere Messages & Codes
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WebSphere Business Integration for
Financial Networks (BIFM)

Websphere Business Integration
Message Broker

Application Performance Analyzer
Messages

Automated Tape Library Messages

Electronic Service Agent

Session Manager z/OS

DFSMS/VM Messages

z/VM Performance Toolkit

z/VM System Messages

z/VM TCP/IP Messages

What’s New in this Release
The new features in this release of MVS/Quick-Ref for Windows have been designed to
enhance the ease of use and flexibility of the product.  This release offers:

A completely new User Interface providing a familiar look and feel for experienced Windows
users.  Wherever possible, menus, toolbars and icons follow the conventions found in
commonly-used Windows programs such as Microsoft® Office™.  The application uses a
Multiple-Document-Interface design so that many windows can be viewed concurrently.

The ‘MVS/Quick-Ref Explorer’ provides a Windows Explorer-style interface to the database
that enables large amounts of information to be easily visualized and navigated. Multiple
‘MVS/Quick-Ref Explorer’ windows can be opened to allow different areas of the database to
be navigated simultaneously.

‘Quick Search’ provides a direct lookup facility that allows the information for any known
message-id, abend code or wait-state to be located with the minimum number of mouse clicks
or keystrokes.

Standard file handling means that MVS/Quick-Ref main and user database files may now be
accessed using the standard ‘open file’ dialog, from any location (network paths, DVDs etc.).
Database files no longer need to reside in a specific path.

File association means that MVS/Quick-Ref database files are linked to the application and
can be opened by double-clicking on them from Windows Explorer.

Dynamic Database Connection allows you to add or remove MVS/Quick-Ref main and user
databases to or from your personal MVS/Quick-Ref setup at the click of a mouse.  There are no
intrinsic limits on the number of databases that you can connect to your session.

Binary Database Compatibility guarantees that your mainframe databases, and databases
from prior MVS/Quick-Ref 5.x (R5.7 or higher) or 6.x releases will work seamlessly with this
release.
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Flexible presentation of information items means that you can control the way database
items are presented. MVS/Quick-Ref uses on-the-fly HTML rendering to insert item text into
HTML templates.  Templates can be customized for vendors or individual products.
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Getting Started

Before you Install
The MVS/Quick-Ref for Windows software needs to be installed on a PC workstation that
satisfies the System Requirements listed below.  Please note that this release of the software is
designed to be installed to the workstation’s local hard disk, not to a shared network path.

The main MVS/Quick-Ref database should also be installed on the workstation’s hard disk to
ensure the best possible performance.  Alternatively, the database can be located anywhere in
the file system available to the workstation, for example on a DVD drive or in a shared folder
on a network file server.

Depending on the distribution media you are using, the main MVS/Quick-Ref database may or
not be included (it is included with DVD media only).  If you are using the downloadable ZIP
archive, only the software is provided, and you will need to either download the database from
your mainframe system (see Advanced Topics) or have a copy already installed on a file server.
You can also use a release 5.7 (or higher) or release 6.x previously-installed database.

Before you proceed with the installation, check that your workstation satisfies the System
Requirements listed below and decide upon the location of the main MVS/Quick-Ref database,
and any user databases you will need.
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System Requirements
The following hardware and software are required to use MVS/Quick-Ref for Windows:

• Intel Pentium 120MHz or equivalent processor running Microsoft® Windows 98 SE,
Windows ME, Windows NT 4.0, Windows 2000, or Windows XP.

• 64MB of RAM, 10Mb of available disk space for the software, and an additional 800MB of
disk space for the main MVS/Quick-Ref database, if installed on your workstation.

• Color monitor capable of displaying 256 colors (16-bit color recommended) at 800 x 600
resolution or higher.

• Microsoft Internet Explorer 5.0 or higher.

• DVD reader.

• Microsoft Visual Basic support files, available free from Microsoft, must be installed. These
are normally installed when Windows is installed, and can also be obtained free from
Microsoft’s download web site at http://msdn.microsoft.com/vbasic/.
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Installation
To install MVS/Quick-Ref for Windows from DVD media:

1. Insert the DVD into the computer’s DVD reader.  If you have the ‘AutoRun’ feature enabled
for your DVD reader, then the set-up application will start automatically.

2. If the setup application does not start automatically, browse the DVD using Windows Explorer
and double-click on the setup.exe application file.

3. Follow the on-screen instructions to complete the installation.

4. If prompted, restart your computer.



Introducing MVS/Quick-Ref for Windows 10

Starting the Program for the First Time
Start the program either by double-clicking on the MVS/Quick-Ref for Windows shortcut on
your Windows desktop, or by choosing the MVS/Quick-Ref for Windows application via the
Windows Start menu.

Before you can use MVS/ Quick-Ref for Windows, you will need to obtain a valid expiration
date code from Chicago-Soft.  The program will prompt you for this the first time it starts.
Enter your expiration date code when the following dialog box appears and click the OK
button.

MVS/Quick-Ref for Windows needs at least one database to work with.  This can be the main
MVS/Quick-Ref database, or a user database.  When you start the program for the first time,
you will need to locate a database.  Click the Yes button when the following dialog box
appears (if you click ‘No’ at this point, the program will close):

If you click on the ‘Yes’ button, the ‘open database’ dialog box will be displayed allowing you
to browse for an MVS/Quick-Ref database on your local hard drive, DVD drive, or network
file system.

The next time you start the program, it will bypass the expiration date and open database
dialogs unless the expiration date has passed, or you have removed all databases from your
session.
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Using MVS/Quick-Ref for Windows

Windows, Toolbars and Menus
This chapter describes the main elements of the application.  MVS/Quick-Ref for Windows
uses a ‘Multiple Document Interface’.  In other words, the application has one main, or ‘parent’
window than contains multiple ‘child’ windows.  When the parent window is minimized, all of
it’s children become invisible.  This approach is generally considered to be more manageable
and easier to work with than having multiple, independent windows on the desktop.

The Application Window
The main application window consists of a menu bar, a toolbar, a status bar and a ‘workspace’
that contains various ‘child’ windows.  To maximize space on smaller screens, the toolbar and
status bar can be turned off from the View menu.

Figure 1 - Main Application Window
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The Menu Bar
The menu bar is shared by the main window and all child windows.  Menu commands act upon
whichever child window has ‘focus’ (is active) at the time.  If no child windows are open, the
menu commands act upon the main window itself.  Because each type of window uses different
menu commands, the menus that appear in the menu bar will change as you move between
windows.

Main Window Menus
The main window offers the following menus:

File Menu:

New Explorer Ctrl+N Opens a new MVS/Quick-Ref Explorer child window
Exit Ctrl+Q Quits the application

View Menu:

Toolbar Toggles toolbar visibility
Status bar Toggles status bar visibility
Expiration Date… Displays Expiration Date dialog

Help Menu:

Help… F1 Opens online help at relevant topic
Technical Support Opens online help at Technical Support topic
About… Displays the application’s ‘about’ dialog
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The Toolbar
Toolbar buttons are used to represent the most commonly used menu commands.  Floating tool
tips are provided to help you recognize the function of each button.  Toolbar buttons are
selectively enabled and disabled (grayed-out) depending on the availability of the related menu
command.

The toolbar provides access to the following commands (from left to right):

Open a new explorer window
File  New Explorer (CTRL+N)
Enabled for all windows.

Save the current item to a file
File  Save… (CTRL+S)
Enabled for viewer window only.

Print the current item
File  Print… (CTRL+P)
Enabled for viewer window only.

Copy selected item text to clipboard
Edit  Copy… (CTRL+C)
Enabled for viewer window only.

Add current item to Textmarks
Edit  Add to Textmarks (CTRL+T)
Enabled for viewer window only, and only where item is not already in the Textmarks collection.

Perform a ‘quick-search’
Locate  Quick Search… (CTRL+Q)
Enabled for explorer window only.

Go to previous item in sequence
Go  Previous Item (CTRL+J)
Enabled for viewer window only, and only where item is part of a sequence.

Go to next item in sequence
Go  Next Item (CTRL+K)
Enabled for viewer window only, and only where item is part of a sequence.

The Status Bar
The status bar is used to display progress messages during long-running operations where the
program is unable to accept any input.  When the program is idle and awaiting user input, the
status bar displays the word “Ready”.
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The MVS/Quick-Ref Explorer Window
The explorer window allows you to easily navigate and search MVS/Quick-Ref database files.
As the name implies, the explorer borrows the familiar Windows Explorer metaphor to visually
represent MVS/Quick-Ref databases as a nested collection of folders and items.

A new explorer window is opened automatically when the program starts.   You can open more
explorer windows from the menu bar by selection File > New Explorer, by clicking the 
toolbar button, or by hitting CTRL+N.  Any number of explorer windows can be open
simultaneously allowing different databases, or different parts of the same database, to be
navigated and searched independently.

The explorer window is a split-pane window with the left-hand pane containing a hierarchical
tree-view of the database and the right-hand pane containing a list-view of information items or
a properties page. The proportion of window area allocated to each pane can be adjusted by
dragging the splitter bar area located between the two panes (the mouse pointer changes to a
sizing cursor  when the pointer is over the splitter bar).

The explorer window has it’s own status bar which is used to display information about the
currently selected item.

Figure 2 - MVS/Quick-Ref Explorer
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The Explorer Tree-View Pane

The tree-view pane has four ‘tabs’ that control the current view of the database:

1. The Vendors Tab

This displays a tree-view of all vendors and products, in all databases, in alphabetical order.
Clicking on a product causes the list-view pane to fill with a list of all information items for
the product.

2. The Products Tab

This displays a tree-view of all products, in all databases, in alphabetical order.

3. The Categories Tab

This displays a tree-view of all categories in all databases in alphabetical order.  Not all
products in the main database are guaranteed to appear in this view, as many products are
uncategorized.  User databases may have no categories at all.

4. The Search Tab

The Search tab displays a query form that you can use to search the database(s) using a
given set of criteria.  The Search facility is described fully, later in this chapter.

Each of the tree-view tabs (vendors, products and categories) maintains its position and state
independently.  This allows three separate areas of the database to be navigated from within a
single explorer window.

The Active Database Selector

MVS/Quick-Ref for Windows can support any number of MVS/Quick-Ref databases (limited
only by system resources).  These can be ‘main’ databases (QDB files) or ‘user’ databases
(UDB files) and may occur in any combination.  Typically, there will be one main database and
zero or more user databases in your personal MVS/Quick-Ref session.

By default, the program will display and search all of the databases it knows about.  In order to
make this situation more manageable, a drop-down menu box exists at the top of the tree-view
pane that enables you to ‘filter’ the databases used in browse and search operations.  Where
only one database is defined, this menu box will be disabled.  Where more than one database is
defined, you may choose to include all databases, or any single database in subsequent browse
or search operations.
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The List-View pane

Like the tree-view pane, the list-view has a number of tabs that control the current view:

1. The Contents Tab

The information displayed in the Contents tab of the list-view pane varies depending on
what type of entity is selected in the tree-view (if any).

When a product is selected, the Contents tab shows a list of information items for that
product.  The list is presented in the order in which items are stored in the database.
Double-clicking on an item, or selecting the item and hitting the return key, will open the
item in a viewer window.

When a database is selected, this pane displays links that can be followed to display
diagnostic information about the database (QINFO) and, in the case of the main
MVS/Quick-Ref database, the ‘What’s New’ topic.

When a vendor is selected, the full, unabbreviated name of the vendor is displayed,
together with a hyperlink to the vendor’s web site.

When a category is selected, the category description is displayed.

2. The Search Results Tab

This shows a list of items found by the last search.   The list is presented in a table with
columns for Item, Product, Release, Vendor and Database.  Any column may be sorted in
ascending or descending sequence by clicking on the column heading.   Search results are
not preserved between sessions.

3. The History Tab

This lists the last 30 items you have opened.  Like the search results list-view, items are
presented in tabular format and may be sorted.  The History trail is preserved between
sessions.

4. The Textmarks Tab

This displays items that have been marked for easy retrieval.  Items are presented in tabular
format and may be sorted.  The Textmark list is preserved between sessions.
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MVS/Quick-Ref Explorer Menus

The following menus are available:

File Menu:

New Explorer Ctrl+N Opens a new MVS/Quick-Ref Explorer window
Open Item Ctrl+O Opens the currently selected information item

Databases
   Add… Adds a database to the session
   Remove Selected Removes the currently selected database

Close Closes this window

Locate Menu:

Quick Search Ctrl+Q Displays the Quick Search dialog

History
   Clear History Clears the history list

Textmarks
   Delete Selected Ctrl+D Deletes the currently selected Textmark item
   Clear All Deletes all Textmarks
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View Menu:

Toolbar Toggles toolbar visibility
Status Bar Toggles status bar visibility
Font… Displays the  Font dialog (plain text only)
Expiration Date… Displays the Expiration Date dialog

Window Menu:

This is the standard ‘window’ menu found in most MDI applications.

Help Menu:

As main window Help menu.

The Explorer Status Bar
The explorer status bar displays location information for the currently selected tree-view item.
If the selected item is a vendor or a category, the number of related products is shown.  If the
selected item is a product, the number of available information items is show.
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The Item Viewer Window
The item viewer window displays the text of an information item.  Once the item text is
displayed in the viewer window, you can find text within it, print it, save it as a file, or copy all
or part of it to the Windows clipboard.

MVS/Quick-Ref for Windows comes with two kinds of item viewer:

1. Plain Text Viewer

The plain text viewer renders the item text in a fixed-pitch font to preserve any
formatting in the text.  Although you can customize the font face, size and color, using
the View > Font… menu command, all items rendered in the plain text viewer are
displayed in the same style.

2. HTML Viewer

The HTML viewer converts the item text to Hypertext Markup Language and displays
it using an embedded version of Microsoft’s Internet Explorer web browser.  The
HTML is generated by merging the item text with a ‘template’ file (see Advanced
Topics).  This allows different styles to be created for each vendor or product.  Because
the item text effectively becomes a web page, elements usually found in web pages
such as hyperlinks and images, can also be included.

Unless your installation uses custom HTML templates for MVS/Quick-Ref, there is no
particular advantage to using the HTML viewer.

The plain text viewer is enabled by default.  To use the HTML viewer, you will need to add the
‘/p’ switch to the command line when starting the application ( ‘QrWin.exe /p’).  You can
do this by changing the properties of the desktop shortcut, or from a console window.  To
revert to the plain text viewer, start the program with the ‘/-p’ switch.
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Item Viewer Menus
The following menus are available:

File Menu:

Save… Ctrl+S Save item text to file
Print Setup… Displays Print Setup dialog
Print… Ctrl+P Sends item text to printer
Close Closes the active window

Edit Menu:

Copy Ctrl+C Copies selected text to clipboard
Select All Ctrl+A Selects all text
Find in Item… Ctrl+F Displays Find dialog (plain text only)
Add to Textmarks Ctrl+T Adds this item to the Textmarks collection
Locate in Contents Ctrl+L Locates this item in the MVS/Quick-Ref explorer

Go Menu:

Previous Ctrl+J Go to previous item in sequence
Next Ctrl+K Go to next item in sequence
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View Menu:

Toolbar Toggles toolbar visibility
Status Bar Toggles status bar visibility
Font… Display Font selection dialog (plain text only)
Expiration Date… Displays Expiration Date dialog

Window Menu:

As MVS/Quick-Ref Explorer Window menu.

Help Menu:

As main window Help menu.

Item Viewer Status Bar
The status bar is only visible when using the plain text viewer.  It shows the location of the
item in the following format:

DB: [database-name] – Vendor: [ISV name] – Product: [product-name] – Rel: [release-level]

The same information is displayed in the body of the text when using the HTML viewer.
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Finding Information

Browsing the Database

Previous versions of MVS/Quick-Ref did not lend themselves particularly well to casual
browsing or information discovery.  One of the major considerations for the current release of
MVS/Quick-Ref for Windows was that the user should be able to ‘take in at a glance’ the
information present in the database, and be able to navigate this information in an intuitive
way.

MVS/Quick-Ref Explorer allows you to browse the database using a familiar ‘tree’ and ‘list’
interface (as used by Windows Explorer).  In this release of MVS/Quick-Ref for Windows, you
can open a database and begin browsing in whatever way you choose, without needing to
perform an initial search.

MVS/Quick-Ref Explorer organizes the information in the database into three hierarchical
‘tree’ structures that represent the order in which information is most commonly accessed: by
Vendor, by Product or by Category.  Each tree can be navigated independently within a single
explorer window by selecting the appropriate tab in the tree-view pane.

The lowest-level ‘leaf node’ in any tree is always a Product and selecting a product (by clicking
on it) causes the list-view ‘contents’ pane to display the information items available within that
product.  Individual information items can then be viewed by double-clicking in the list-view
‘contents’ pane.

If you have more than one database in your session, you can limit your browsing to a single
database by using the Active Database selector in the explorer window.  You can open multiple
MVS/Quick-Ref explorer windows if you need to browse or search different databases, or parts
of the same database, independently.
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Searching for Information

You can use the Search tab of the MVS/Quick-Ref Explorer to search the database:

Figure 3 – The Search Tab

The search tab allows the following criteria to be specified:

• Vendor
• Product
• Release
• Item

At least one of these ‘key’ fields must be specified.  Placing the wildcard character (an asterisk) at
the end of the key allows generic keys to be used (e.g. ‘Chicago*’).
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Searching for text within items
Items matching the specified keys can be further searched for a string specified in the
‘Containing Text’ field.  Additional refinement is provided by the ‘Match Case’ and ‘Match
Whole Word Only’ controls in the Search Options panel (see below).

Search Options

Clicking on Search Options >> reveals the following additional options:

• Match Case

Checking this box forces case-sensitive text matching.

• Find Whole Word Only

Checking this box forces match of whole words.  For example if you enter ‘author’ in the
Text field, the strings ‘authority’ and ‘authorized’ would be matched by default.  Checking
this option causes the text to be matched only if it exists as a distinct word (that is, only
‘author’ will be found).

• Limit Search to ‘n’ Items

This sets the maximum number of items returned by key field matching.  Any number
between 1 and 999,999 may be specified.  If no limit is specified, or if zero is specified, the
value defaults to 100.

Note that this limit is applied before any text searching takes place.

Clicking the [Search] button starts the search process.

Clicking the [Clear] button causes all search fields and search results to be cleared.

Searching with Multiple Database
If you have multiple databases defined in your MVS/Quick-Ref session, you can specify which
database to search by using the MVS/Quick-Ref Explorer’s ‘Active Database’ control.
Otherwise, all databases are searched in the order they appear in the tree-view.  If the search
limit is reached, databases below the one being searched will be ignored.
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Using Quick Search

If you know the exact message number, code or other item that you are looking for, you can
use the Quick Search facility to go directly to the item.  If there is only one item for that
message number or code, the item will be opened immediately.  If there is more than one
possible match, a list of matching items will be displayed in the Search Results tab of the
MVS/Quick-Ref explorer window.  Quick Search will also accept partial message numbers and
codes followed by the wildcard character (‘*’).

To use Quick-Search, select Locate > Quick Search (CTRL+Q) from the MVS/Quick-Ref
Explorer menu bar or click on the  toolbar button.  The Quick Find dialog box will be
displayed allowing you to enter the message number or code you are seeking.  Click the [OK]
button to begin searching.

Using Textmarks

Textmarks provide a shortcut to the information items you refer to most often.  A list of your
current Textmarks is displayed in the Textmarks tab of the MVS/Quick-Ref Explorer.

To add an item to the Textmarks list, display the item you want to mark, then choose
Edit > Add to Textmarks (CTRL+T) from the menu.  You can also use the  toolbar button.
There is no limit to the number of Textmarks you can add.

To display a textmarked item, go to the Textmarks tab of the MVS/Quick-Ref Explorer and
double click the item, or select the item and hit the return key.

To delete a Textmark, go to the Textmarks tab of the MVS/Quick-Ref Explorer and select the
Textmark you want to delete then choose Locate > Textmarks > Delete Selected from the
menu, or hit CTRL+D.

You can delete all of your Textmarks by choosing Locate > Textmarks > Clear All from the
menu bar.
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Using History

MVS/Quick-Ref Explorer keeps track of the last 30 items you have opened.  This allows you to
return to these items quickly without having to re-find them or Textmark them.

To display an item in the History list, go to the History tab of the MVS/Quick-Ref Explorer
and double click the item, or select the item and hit the return key.

You can clear the History list at any time by choosing Locate > History > Clear History from
the menu.

Finding Text in Displayed Items

The procedure for finding text within an information item varies slightly depending on whether
you are using the Plain Text viewer or the HTML viewer:

Finding Text in the Plain Text Viewer

Choose Edit > Find in Item (CTRL+F) from the menu bar to display the Find dialog box.

Figure 4 - Find Dialog (plain text viewer)

Finding Text in the HTML Viewer

Click anywhere on the text of the information item then hit CTRL+F to display the Internet
Explorer Find dialog box.

Figure 5 – Internet Explorer Find Dialog (HTML viewer)
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Locating an item in the tree-view

Where an information item is opened from the Search Results, History or Textmark lists, it is
often useful to be able to locate the product that contains that item in the tree-view of the
MVS/Quick-Ref Explorer window.  This can be done from the Item Viewer window by
choosing Edit > Locate in Contents (CTRL+L) from the menu bar.

The product containing the item will be located and displayed in the Vendors tab of the tree-
view pane.  If no explorer windows are open at the time, one will be opened automatically. If
multiple explorer windows are opened, the last one to be opened will be used.

Linked Items
Some product entries have information items that are linked together so that they can be read
sequentially.  In this case, you can move backwards and forwards through the linked items
choosing Go > Previous (CTRL+J) and Go > Next (CTRL+K) from the menu bar or by
clicking on the  and  toolbar buttons.
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Working With Databases

About MVS/Quick-Ref Databases
There are two kinds of MVS/Quick-Ref databases:  ‘main databases’ are supplied by Chicago
Soft and contain reference information for IBM and third-party software that runs on under the
MVS operating system; ‘user databases’ are created by you or your site, using the mainframe
version of MVS/Quick-Ref and contain reference information specific to you and your
organization.  User databases cannot be created with MVS/Quick-Ref for Windows.

An MVS/Quick-Ref database is an indexed binary file that allows large quantities of
information to be stored efficiently and accessed quickly.  Information in the database is
compressed, and in the case of the main database, encrypted.  In the Windows version of the
product, main databases have the file extension QDB and user databases have the extension
UDB.  MVS/Quick-Ref’s file extensions are registered with Windows the first time the
program is run.  This allows database files to be ‘associated’ with the MVS/Quick-Ref for
Windows application so that they are correctly identified and handled by Windows Explorer.

Both main and user databases share the same structure and binary file format.  The file format
is identical for both mainframe and Windows versions of MVS/Quick-Ref, allowing you to
download databases to your workstation or file server and use them immediately.

Adding a Database
MVS/Quick-Ref for Windows can work with a single main or user database, or with any
combination of main and user databases.

Normally, all databases defined to your personal MVS/Quick-Ref session are available for
browsing and searching in the MVS/Quick-Ref explorer window.  If you want to limit
browsing and searching to a single database you can use the explorer’s ‘Active Database’
control.

To add a database to your session, choose the File > Databases > Add… command from the
menu bar then browse for the database file you want to add.

Be aware that the order in which databases are added affects the results of any search.
Databases are searched in the order they appear in the tree-view unless you confine searching
to a specific database.  If the search limit count is reached in the database at the top of the tree,
the databases below will not be searched.  You can change the order of the databases by
removing all databases and re-adding them in the desired order.
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Removing a Database
To remove a database from your session, select the database in the tree-view of the
MVS/Quick-Ref explorer window then choose File > Databases > Remove Selected from the
menu bar.

It is perfectly possible to remove all databases from your session and you may want to do this
when changing the database search order.  If you start MVS/Quick-Ref without any databases,
the program will prompt you to locate one.

Downloading Databases from the Mainframe
Any release 5.7 (or higher) or 6.x database can be used with MVS/Quick-Ref for Windows.
Because the binary format of the database is identical to that used by the mainframe product,
you can simply download the file directly to your PC workstation or file server and open it.

You can download a database using any of the file transfer utilities included with popular 3270
emulator products, or you can use FTP.  Whichever method you choose, it is important that you
transfer the database as a binary file, not as an ASCII text file.
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Accessing the QINFO Diagnostic Tool
Chicago-Soft support personnel may ask you to use the QINFO tool to provide them with
additional information when debugging MVS/Quick-Ref for Windows database problems.
QINFO is available in the MVS/Quick-Ref for Windows explorer window by selecting a
database and clicking on the hyperlink displayed in the contents tab.  You can select the text in
the scrollable area of the dialog and paste it into an email or document:
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Getting Help

Online Help
As you work with the product, remember that on-line help information is available at any time
by selecting Help > Help… from the menu bar, or by pressing the F1 key.

Contacting Chicago-Soft

DISTRIBUTION CENTER AND TECHNICAL SUPPORT

Chicago-Soft, Ltd.
6232 North Pulaski Road, Suite 402
Chicago, Illinois 60646-5131
USA

Phone: 773-282-4777
FAX: 773-282-9036
Technical Support E-mail: support@quickref.com
Expiration Date Zap E-mail: zap@chicago-soft.com
Web: http://www.chicago-soft.com

SALES OFFICE

Chicago-Soft, Ltd.
1 Maple Street
Hanover, New Hampshire 03755
USA

Phone: 603-643-4002
FAX: 603-643-4571
E-mail: chisoft@chicago-soft.com
Web: http://www.chicago-soft.com
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Advanced Topics

Starting the Program from Command Line

MVS/Quick-Ref for Windows can be started from the command line as follows:

QrWin.exe /[-]p /r [database-filename]

Where:

/p Use plain text item viewer for this and all subsequent sessions.

/-p Use HTML item viewer for this and all subsequent sessions.

/r Remove all databases from user profile

Note that when the program is started with a database filename, this overrides your database
configuration for the current session.  This is also the case when the program is started by a file
association (e.g. by double-clicking on a file with a  ‘.QDB’ or ‘.UDB’ extension).

The Vendor Information file

MVS/Quick-Ref for Windows can display the full name of a vendor as well as the vendor’s
web site URL.  This information is not present in the MVS/Quick-Ref database but is
contained in the vendorinfo.txt file.  This file is installed in the same directory as the
QrWin.exe application.

The file contains one line for each vendor in the following format:

{vendor-short-name}|{vendor-full-name}|{vendor_url}

For example:

CHICAGO-SOFT|Chicago-Soft, Ltd.|http://www.chicago-soft.com

The ‘vendor-short-name’ value must match the vendor name as it appears in the MVS/Quick-
Ref explorer.
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HTML Templates

HTML Templates allow the appearance of information items to be customized when displayed
in MVS/Quick-Ref’s HTML viewer.  For example, the Vendor’s logotype and corporate color
scheme might be used.  Hyperlinks to the vendor’s web sites, or other relevant URLs could
also be included.

Templates are standard HTML documents that use special tags to represent MVS/Quick-Ref
content.  When MVS/Quick-Ref for Windows constructs the page, these special tags are
replaced with the appropriate content.

Template tags have the form <?$symbol?> and can be any of the following:

Symbol Content
<?$apptitle?> Application title (i.e. MVS/Quick-Ref…)
<?$copyright?> Copyright information for the item
<?$database?> Database in which the item exists
<?$item?> Item name
<?$itemtext?> The text of the item
<?$prodrel?> Combined product name and release name
<?$product?> Product name
<?$release?> Release name
<?$templatepath?> Path containing the document template
<?$vendor?> Vendor name

HTML Templates are located in the \Templates folder (or one of it’s subfolders) in the
installation path and have the file extension ‘.htm’.  The \Templates folder is created
automatically by MVS/Quick-Ref for Windows if it doesn’t already exist.

The default template is named ‘default.htm’ and is used by the HTML item viewer if no
vendor or product-related template exists.  Any resources used by this template (GIF files etc.)
should be placed in the same folder as the template file.

Templates specific to vendors should be placed in a subfolder of the \Templates folder.  The
subfolder name should be the same as the vendor name except that spaces and special
characters should be replaced by underscore characters.  For example, if a custom template
existed for the vendor ‘Software AG’, then the subfolder would be \Templates\
software_ag.

Vendor-specific subfolders should contain a ‘default.htm’ template file that defines the
layout and style for all products supplied by that particular vendor.  If a product-specific
template is required, it should be placed in the vendor’s subfolder and given the name of the
product (observing the rule of translating spaces and special characters to underscores).  For
example, if IBM’s DB2 product required a product-specific template, the template path would
be: ‘\Templates\IBM\db2.htm’.
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Error Messages

Message: {error-description} ({error-code}) Error Saving File

Explanation: An error occurred when attempting to save a file from the item viewer window.
The error description and code are obtained from the Windows file system.
This error commonly occurs when the device to which the file is being saved is
full or inaccessible.  It can also occur if you do not have the access rights
necessary to create the file.

Message: {product name} is present in index but no items can be found

Explanation: The named product was found in the database index but no corresponding
information items could be found.  This indicates that the database has been
incorrectly built or has been corrupted.

Message: Unable to load product information from {database name}

Explanation: No product information could be loaded from the named database.
This indicates that the database has been incorrectly built or has been corrupted.

Message: Unrecoverable Error – RC = {code} in database {database name}

Explanation: This message indicates a general failure in the QXPDATA.DLL or
QWIKSUBS.DLL access method modules.  The following table describes the
return code values associated with this message:

Return Code Description
1xxx QXPDATA Errors
1001 Unexpected return code from QWIKSUBS
1002 Out of Memory
1003 Incorrect Database Version
2xxx QWIKSUBS Errors
2020 ‘fopen’ Failure, ‘fseek’ Error, Stack Over/Underflow
2021 Unexpected end-of-file
2022 File read/write error
2024 Database Open Failure
2044 Index Processing Failure
2104 Bad Block Encountered in Database File


